cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reinhard Pötz <reinh...@apache.org>
Subject Cocoon-jms-sample requires Java >= 1.5
Date Wed, 30 Jul 2008 12:49:54 GMT
Now we have the problem that the ActiveMQ version that we use was built 
with Java 5:

[ERROR] BUILD FAILURE
[INFO] 
------------------------------------------------------------------------
[INFO] Compilation failure
/home/continuum/data/working-directory/51/blocks/cocoon-jms/cocoon-jms-sample/src/main/java/org/apache/cocoon/jms/SimpleTextMessagePublisher.java:[22,-1]

cannot access org.apache.activemq.command.ActiveMQTextMessage
bad class file: 
/home/continuum/.m2/repository/org/apache/activemq/activemq-core/5.1.0/activemq-core-5.1.0.jar(org/apache/activemq/command/ActiveMQTextMessage.class)
class file has wrong version 49.0, should be 48.0

/home/continuum/data/working-directory/51/blocks/cocoon-jms/cocoon-jms-sample/src/main/java/org/apache/cocoon/jms/SimpleTextMessagePublisher.java:[22,-1]

cannot access org.apache.activemq.command.ActiveMQTextMessage
bad class file: 
/home/continuum/.m2/repository/org/apache/activemq/activemq-core/5.1.0/activemq-core-5.1.0.jar(org/apache/activemq/command/ActiveMQTextMessage.class)
class file has wrong version 49.0, should be 48.0


According to 
http://activemq.apache.org/can-i-use-activemq-5x-or-later-on-java-14.html 
there is no version built for 1.4.

What shall we do?

-- 
Reinhard Pötz                           Managing Director, {Indoqa} GmbH
                          http://www.indoqa.com/en/people/reinhard.poetz/

Member of the Apache Software Foundation
Apache Cocoon Committer, PMC member                  reinhard@apache.org
________________________________________________________________________

Mime
View raw message