cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kamal Bhatt <kbh...@tt.com.au>
Subject Re: Cocoon-fop-impl using old version of fop.jar
Date Mon, 30 Jun 2008 23:41:27 GMT
This has been done in trunk (I think)

https://svn.apache.org/repos/asf/cocoon/trunk/blocks/cocoon-fop/cocoon-fop-ng-impl/

I don't know why this hasn't been released, a committer can give more 
information on what needs to be done to make this a stable, released block.

Unfortunately, when the Fop crew moved to 0.9x they completely rewrote 
the API for embedding which makes the upgrade a little more difficult 
than simply changing the version number.

Also, 0.9x works very differently to 0.20.5. From my understanding 
0.20.5 had many deviations from the XSL FO standard, which were 
rectified in 0.9x. This means that there are probably many people out 
there who would scream bloody murder if we simply moved to 0.9x as all 
their stylesheets would break.

I assume the reason why both 0.20.5 and 0.9x were not supported in the 
same transformer was because of clashing classes.

For more details see here:

http://xmlgraphics.apache.org/fop/0.94/upgrading.html

> Hi guys,
>
>  
>
> Any particular reason why we still use the DINO-version of the fop.jar 
> (0.20.5) ?
>
>  
>
> I would like to use at least the stable 0.94 or even try out the 0.95 
> beta.  What is the easiest way to accomplish this?
>
>  
>
> Currently I have just added the FOP-dependency to my pom like below:
>
>  
>
>     <dependency>
>
>       <groupId>org.apache.cocoon</groupId>
>
>       <artifactId>cocoon-fop-impl</artifactId>
>
>       <version>1.0.0</version>   
>
>     </dependency>
>
>  
>
>  
>
> Any help would be most appreciated.
>
>  
>
> Cheers,
>
> Robby Pelssers
>


-- 
Kamal Bhatt


Mime
View raw message