cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Grzegorz Kossakowski <g...@tuffmail.com>
Subject Increase required Maven version to 2.0.9+
Date Sat, 28 Jun 2008 19:02:34 GMT
Hi,

Cocoon's trunk requires[1] version 2.0.6+ of Maven:
         <executions>
           <execution>
             <id>enforce-maven</id>
             <goals>
               <goal>enforce-once</goal>
             </goals>
             <configuration>
               <rules>
                 <requireMavenVersion>
                   <version>[2.0.6,)</version>
                 </requireMavenVersion>
               </rules>
             </configuration>
           </execution>
         </executions>

I would like to increase the required version to 2.0.9+ for several reasons:
1. Thanks to David's Legg efforts we switched to Archetype 2.0 Maven plug-in for blocks/webapp

creation process, see COCOON-2214[2]. The latest release of Aechetype requires 2.0.9.
2. There are fixes for several annoying bugs including those affecting us like infamous MNG-2782.
3. Since 2.0.9 or 2.0.8 (not sure really) Maven team has decided to lock up plug-in's default

versions. This is a really good idea and we should enforce it on our users in order to avoid

troubles that will hit our user's mailing list soon or later.

If there are no voice of objection I'll commit this change tomorrow.

[1] http://svn.eu.apache.org/repos/asf/cocoon/trunk/parent/pom.xml
[2] https://issues.apache.org/jira/browse/COCOON-2214

-- 
Best regards,
Grzegorz Kossakowski

Mime
View raw message