cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Grzegorz Kossakowski <g...@tuffmail.com>
Subject Re: 2.2 is not building
Date Wed, 11 Jun 2008 21:06:53 GMT
Lochschmied, Alexander pisze:
>>>>> org.apache.cocoon:cocoon-pipeline-impl:jar:1.1.0-SNAPSHOT
>>>>> is still missing, see attached log if you want
>>>> Sorry, actually it's a little different now. The missing artifact
> now is
>>>> org.apache.cocoon:cocoon-configuration-api:jar:1.0.3-SNAPSHOT
>>> I'm testing this locally.
>>>
>>> BTW. What version of Maven do you use?
>>>
>>> You might try without allblock profile first.
> 
>> I've built latest trunk (allblocks) without any trouble so this must
> be something specific to your
>> configuration.
> 
>> Do you use latest Maven release?
> 
> Grzegorz, I was using Maven 2.0.7 and I tried it with latest (2.0.9) and
> I tried plain 'mvn install' (with Java 1.6.0_02), it still gives build
> error because of missing
> 'org.apache.cocoon:cocoon-configuration-api:jar:1.0.3-SNAPSHOT'. I've
> tried this for now r664664.
> 
> One really confusing thing is that it does work (!) with a backup
> version (from May) of ~/.m2/repository and it fails if this directory is
> empty.

Alexander, I don't really know what the exact problem is with your configuration but David

stumbled[1] across a similar problem to yours and resolved[2] it rather easily.

Could you try following list of commands:
mvn clean -P allblocks
rm -rf ~/.m2/repository
mvn install -P allblocks

All with Maven 2.0.9.

I hope it'll finally work for you.

[1] http://article.gmane.org/gmane.text.xml.cocoon.user/64789
[2] http://article.gmane.org/gmane.text.xml.cocoon.user/64798


-- 
Grzegorz Kossakowski

Mime
View raw message