cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robin Wyles <...@robinwyles.com>
Subject Re: Little announcement and ask for a help
Date Fri, 30 May 2008 15:56:47 GMT
Hi Grzegrorz...

You were right... when I extracted from the command line I could see  
the files.

Anyway, I ran

mvn eclipse:clean eclipse:eclipse
grep sourceresolve .classpath

and got no output...

I did the same in for the dirtylicious-theme block and again, got no  
output from grep.

I then imported the dirtylicious-theme block as a project into  
Eclipse and tried to debug it using a Jetty webapp config. Sure  
enough, I get a java.lang.NoClassDefFoundError: org/apache/excalibur/ 
source/SourceValidity.

As an aside, I'm developing a number of C2.2 blocks with Eclipse and  
also debug them using a Jetty Webapp, configured in Eclipse, and I  
don't remember running into this sort of issue before.

Cheers,

Robin

On 30 May 2008, at 16:12, Grzegorz Kossakowski wrote:

> Jeroen Reijn pisze:
>> Hi Robin,
>> I tried it as well. You should do a maven install in all  
>> subfolders of
>> the project before trying to run the mvn jetty:run.
>> Nice project btw Greg! I would like to participate, but I do not  
>> see any
>> spare time in the near future. Looks good though! I've been  
>> wanting to
>> create a blog application with 2.2 as a test project as well. Good to
>> see you actually started.
>
> Thanks Jeroen for your kind comments.
>
> I don't expect it to be a big project (I have not enough time to  
> invest into it) so even small contributions can be very valuable.  
> The best part is that you can always clone my repository and try to  
> play around and send me patches over e-mail if you find results  
> worth contributing back to the project. There is no need to  
> officially pledge your commitment. All in all, it's open source. ;-)
>
> At the moment the most urgent issue is to find out whether my  
> problem with eclipse:eclipse plug-in can be confirmed by others. If  
> so, bug report should be created ASAP because this annoying problem  
> affects probably all Cocoon (and Eclipse) users.
>
> If anyone could run (in main block):
> mvn eclipse:clean eclipse:eclipse
> grep sourceresolve .classpath
>
> and paste results here I would be very grateful.
>
> -- 
> Grzegorz Kossakowski
>


Mime
View raw message