cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Grzegorz Kossakowski <g...@tuffmail.com>
Subject Re: Little announcement and ask for a help
Date Thu, 29 May 2008 21:37:42 GMT
Grzegorz Kossakowski pisze:
> Hi guys,
> 
> I've been rather inactive these days mainly busy with personal affairs 
> but also with Cocoon 2.2 demo application coding. The thing is hosted on 
> github, project called cocoon-blog[1].
> 
> The project status should be considered as highly unstable. There is 
> quite a lot of interesting functionality already implemented like DAOs 
> in JS, jDBI (2.0.x) integration, configuration of HSQL, dirtylicious 
> theme, etc. but all these pieces are not integrated with each other yet.
> 
> At the moment, I'm facing some annoying problem that effectively stops 
> me from developing further given my (very) limited resources these days. 
> The problem is with debugging blocks in Eclipse. I'm using run-jetty-run 
> plugin[2] for running blocks inside Eclipse.
> 
> In the past this technique worked very well together with 
> eclipse:eclipse plug-in that allowed me to import block into Eclipse's 
> workspace. Normally, following steps should work: (assuming 
> run-jetty-run is installed):
> 1. Go to block (e.g. dirtylicious-theme)
> 2. Run mvn clean cocoon:prepare
> 2. Run mvn eclipse:eclipse
> 3. Import block into workspace
> 4. Create Debug configuration of "Jetty Webapp" type. As webapp dir 
> property value set "target/rcl/webapp".
> 5. Run debugging of block.
> 
> As I said, this worked very well in the past but for some unknown reason 
> I'm facing lots of classpath issues. The latest is:
> Caused by: java.lang.NoClassDefFoundError: 
> org/apache/excalibur/source/SourceValidity
> 
> I've checked dirtylicious-theme block imported to Eclipse and there is 
> no sourceresolve dependency created by eclipse:eclipse but 
> dependency:list shows it.
> 
> I would like to ask other folks for a help with confirming if it's a 
> common problem and maybe finding some solution to this problem. Of 
> course, I could figure out all missing dependencies and add them by hand 
> but we use Maven for some reason, do we?
> 
> So go to http://github.com/gkossakowski/cocoon-blog/tree/master, click 
> on Download button and test my steps please. I will be very grateful for 
> any feedback.

I forgot to add that in order to compile cocoon-blog you need to have a build of up-to-date
Cocoon 
trunk. See this README for more details:
http://github.com/gkossakowski/cocoon-blog/tree/master/README

-- 
Best regards,
Grzegorz Kossakowski

Mime
View raw message