cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Pruy <Rainer.P...@Acrys.COM>
Subject Re: Rename cocoon:rcl to cocoon:wrap-block
Date Wed, 20 Feb 2008 15:29:23 GMT
Then....

cocoon:prepare

or (more verbose)

cocoon:prepare-run

does sound appropriate....

Jason Johnston schrieb:
> Reinhard Poetz wrote:
>> Felix Knecht wrote:
>>> Reinhard Poetz schrieb:
>>>>
>>>> After having seen quite a few people wonder what 'cocoon:rcl' means,
>>>> I propose to change it to some better name.
>>>>
>>>> The general idea is that this Maven goal creates a web application
>>>> which wraps the block and makes it runable as a 'normal' web
>>>> application in a web container. Additionally it enables the usage of
>>>> the reloading classloader (commons-jci) which made me name it
>>>> 'cocoon:rcl'.
>>>>
>>>> I propose to use 'cocoon:wrap-block' instead. Though it's longer I
>>>> think it's closer to the actual meaning and hence less confusing. If
>>>> we want to keep the name short, we could even add a shortcut
>>>> 'cocoon:wb'.
>>>>
>>>> WDOT? Other proposals?
>>>>
>>> cocoon:run
>>
>> Actually it doesn't run the block but only creates the environment
>> (i.e. a web application that wraps a block) for it.
>>
> 
> cocoon:package
> cocoon:assemble
> 
> (Though "package" has a specific connotation in the Maven world of
> creating a jar/war/etc. ... does this goal do that as well?)

Mime
View raw message