cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Torsten Curdt <>
Subject Re: Rename cocoon:rcl to cocoon:wrap-block
Date Sat, 16 Feb 2008 16:44:37 GMT

On 16.02.2008, at 17:12, Reinhard Poetz wrote:

> After having seen quite a few people wonder what 'cocoon:rcl'  
> means, I propose to change it to some better name.
> The general idea is that this Maven goal creates a web application  
> which wraps the block and makes it runable as a 'normal' web  
> application in a web container. Additionally it enables the usage  
> of the reloading classloader (commons-jci) which made me name it  
> 'cocoon:rcl'.
> I propose to use 'cocoon:wrap-block' instead. Though it's longer I  
> think it's closer to the actual meaning and hence less confusing.  
> If we want to keep the name short, we could even add a shortcut  
> 'cocoon:wb'.

"wrap-block" ??? Hm ...I cannot really see how that is much better -  
sorry ;)

What about "cocoon:webapp-loader"


View raw message