cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeroen Reijn (JIRA)" <j...@apache.org>
Subject [jira] Commented: (COCOON-2153) DaslTransformer fails because of conflicting http client dependencies
Date Wed, 05 Dec 2007 22:16:43 GMT

    [ https://issues.apache.org/jira/browse/COCOON-2153?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12548841
] 

Jeroen Reijn commented on COCOON-2153:
--------------------------------------

Since all other blocks have switched to httpclient 3.0.1 we need to see if it is possible
to upgrade the slide dependency to use a newer version of the http client or we should take
a look at a different webdav library to use in Cocoon.

> DaslTransformer fails because of conflicting http client dependencies
> ---------------------------------------------------------------------
>
>                 Key: COCOON-2153
>                 URL: https://issues.apache.org/jira/browse/COCOON-2153
>             Project: Cocoon
>          Issue Type: Bug
>          Components: Blocks: WebDAV
>    Affects Versions: 2.2-dev (Current SVN)
>            Reporter: Jeroen Reijn
>            Assignee: Jeroen Reijn
>             Fix For: 2.2-dev (Current SVN)
>
>
> While using the webdav block in your cocoon 2.2 application the DaslTransformer will
fill fail with a NoSuchMehtod exception on the setCredentials in the DASL transformer. After
further investigation it appeared the the 'slide'  dependency has a dependency on commons-httpclient
version 2.0.2 and the webdav block has a dependency for 3.0.1. These two dependencies conflict
with each other.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message