cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonio Gallardo (JIRA)" <j...@apache.org>
Subject [jira] Closed: (COCOON-1251) XSP compile failure when using Java 1.5 features
Date Thu, 29 Nov 2007 05:13:43 GMT

     [ https://issues.apache.org/jira/browse/COCOON-1251?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Antonio Gallardo closed COCOON-1251.
------------------------------------

       Resolution: Fixed
    Fix Version/s: 2.1.11-dev (Current SVN)

Fixed by Alfrad Nathaniel in:

http://svn.apache.org/viewvc?view=rev&revision=555089

> XSP compile failure when using Java 1.5 features
> ------------------------------------------------
>
>                 Key: COCOON-1251
>                 URL: https://issues.apache.org/jira/browse/COCOON-1251
>             Project: Cocoon
>          Issue Type: Bug
>          Components: Blocks: XSP
>    Affects Versions: 2.1.5
>         Environment: Operating System: Linux
> Platform: PC
>            Reporter: Thomas Zehetbauer
>            Assignee: Antonio Gallardo
>             Fix For: 2.1.11-dev (Current SVN)
>
>
> I am trying to use the new JDK1.5 foreach loop in XSP, basically:
> List entries = new ArrayList();
> for (Map entry: entries) {
>         ...
> }
> which causes the following error with the default EclipseJavaCompiler:
> // start error (lines 1003-1003) "Syntax error on token ":", ";"
> expected"
>                                                 for (Map entry: entries)
> {
> // end error
> or even with the Javac compiler:
> /home/tomcat/work/Default/beta.hostmaster.org/_/cocoon-
> files/org/apache/cocoon/www/Dictionary_xsp.java:1003: ';' expected.
>                                                 for (Map entry: entries)
> {
> Cocoon is running under Tomcat 5.0.28 on j2sdk-1.5.0-beta2-b51.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message