cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Giacomo Pati <giac...@otego.com>
Subject Re: pipelineComponent scope troubles (was Code freeze?)
Date Thu, 20 Sep 2007 20:29:48 GMT
On Thu, 20 Sep 2007, Grzegorz Kossakowski wrote:

> Date: Thu, 20 Sep 2007 18:54:24 +0200
> From: Grzegorz Kossakowski <gkossakowski@apache.org>
> Reply-To: dev@cocoon.apache.org
> To: dev@cocoon.apache.org
> Subject: Re: pipelineComponent scope troubles (was Code freeze?)
> 
> Grzegorz Kossakowski pisze:
>>
>> When looking at this issue and the stacktrace you have given above I'm feeling like
having Déjà vu.
>> I have experienced problem with UnmodifiableMap at the time I made the commit you
mentioned and I
>> thought that I had fixed it immediately. It turns out that I must have forgot to
do it and lost my
>> fix while upgrading my hardware...
>>
>> I'm going to find a proper fix now. Thanks for reporting.
>
> Ehkm. After digging the code I came to conclusion that this issue has been fixed, after
all...
>
> The fix was pretty naive and made in r567433 (my next commit after r567329), see:
> http://article.gmane.org/gmane.text.xml.cocoon.cvs/25006

I've tried current trunk as well and it seems that the stack trace I've 
reported earlier is gone now and I'm again at the NPE from jexl. After 
some debugging as you told me, I can confirm that the failing request of 
my app is using the one and only OM instance created during that request. 
I can also see the status object being put into it and fetched later again 
with a "myTasks" attribute which _is_ a List having a size of 0 but jexl 
still barfs the NPE "cannot evaluate 'status.myTasks.size()'?!?!?! 
Which makes me believe it could be a Jexl problem. Did we changed Jexl 
version???

I'm stuck again.

-- 
Otego AG                                  Tel:   +41 (0)1  240 00 55
Giacomo Pati, CTO                         Mobile:+41 (0)79 262 21 04
Apache Software Foundation Member         Mailto:giacomo@apache.org
Hohlstrasse 216                           Mailto:Giacomo.Pati@otego.com
CH-8004 Zürich                            http://www.otego.com

Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message