cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reinhard Poetz <reinh...@apache.org>
Subject Re: Java 1.5
Date Fri, 28 Sep 2007 05:31:27 GMT
Joerg Heinicke wrote:
> On 25.09.2007 15:45 Uhr, Vadim Gritsenko wrote:
> 
>> Our problem is not minimum Java requirement for Cocoon 2.2. The 
>> problem is release time lines. [..] Java requirements? Nah, that's 
>> peanuts...
> 
> Thanks, you hit the nail. When was the vote? 1 year ago?
> 
> Despite being still convinced that raising the requirement to Java 5 
> does not buy as a lot if anything (Just think of java.nio, which is 
> supposed to bring a big performance gain and would so be a real 
> advantage for the user. I never saw ANY code in Cocoon using it.) I 
> herewith withdraw my -1 since I'm just tired of discussing this over and 
> over again.

I finally managed to create all the release artifacts. The problem was that 
hardly any (or nobody) of the committers is using Maven 2 with Java 1.4. (The 
funny thing is that our Continuum instance does not suffer from this problems.) 
This combination leads to some problems and I was tired of fixing them just for 
the sake of a release.

I think for 2.2 it is fine to stick with Java 1.4 and go for Java 5 with 2.3. 
This should also give the Websphere 6 users enough time and is for all the Java 
  5 fans motivation to make 2.3 happen soon ;-)

-- 
Reinhard Pötz           Independent Consultant, Trainer & (IT)-Coach 

{Software Engineering, Open Source, Web Applications, Apache Cocoon}

                                        web(log): http://www.poetz.cc
--------------------------------------------------------------------

Mime
View raw message