cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <>
Subject Re: Java 1.5
Date Fri, 28 Sep 2007 05:09:40 GMT
On 28.09.2007 0:46 Uhr, Ralph Goers wrote:

> However, the language features of 1.5 are worth it.
> For example, I would love to replace some pieces of 
> code that require synchronized blocks with java.util.concurent.  I would 
> love to be able to specify the object types on Maps and Lists. It just 
> makes for better code.

That's unlikely to happen before the release I guess. Maybe you should 
have this in mind when deciding about the requirement for Cocoon 2.2 - 
even if this locks it to 1.4. java.util.concurrent is also available as 
backwards-compatible version for 1.4.


View raw message