cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ralph Goers <Ralph.Go...@dslextreme.com>
Subject Re: Java 1.5
Date Fri, 28 Sep 2007 04:46:49 GMT
Joerg Heinicke wrote:
> On 25.09.2007 16:20 Uhr, Felix Knecht wrote:
>
>> May I ask why can't just make a jump and goto java 1.6?
>> What's the benefit of using not the latest version - do any contracts
>> exists that we can't jump over a java version?
>
> And what's the use of it? I just don't get it why a framework should 
> set restrictions on its user base. While nothing prevents you to use 1.6.
>  
I don't necessarily agree with setting 1.6 as the minimum myself. Mostly 
because it doesn't add much over 1.5. However, the language features of 
1.5 are worth it. For example, I would love to replace some pieces of 
code that require synchronized blocks with java.util.concurent.  I would 
love to be able to specify the object types on Maps and Lists. It just 
makes for better code.  I'm sure we could find a way to take advantage 
of NIO if we really thought about it.  But we can't do any of that 
because we are stuck at 1.4.

Ralph

Mime
View raw message