cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Grzegorz Kossakowski <gkossakow...@apache.org>
Subject Re: pipelineComponent scope troubles (was Code freeze?)
Date Thu, 20 Sep 2007 20:48:24 GMT
Giacomo Pati pisze:
> I've tried current trunk as well and it seems that the stack trace I've
> reported earlier is gone now and I'm again at the NPE from jexl. After
> some debugging as you told me, I can confirm that the failing request of
> my app is using the one and only OM instance created during that
> request. I can also see the status object being put into it and fetched
> later again with a "myTasks" attribute which _is_ a List having a size
> of 0 

Good to hear that. We have at least can remove large portion of code from the list of suspected.

> but jexl still barfs the NPE "cannot evaluate
> 'status.myTasks.size()'?!?!?! Which makes me believe it could be a Jexl
> problem. Did we changed Jexl version???
> 
> I'm stuck again.

I'm sure that we have not upgraded Jexl for at least three months.

Any chance to reproduce this behaviour with my little sample? I tried to modify it so empty
List is
passed but everything works fine. Is your list a standard Java implementation like ArrayList?
Isolating the problem that anyone can test on its own machine is crucial here, really. Or
you can
just consider debugging Jexl yourself, it's has source code written decently.

Thank you for quick response.

-- 
Grzegorz Kossakowski
Committer and PMC Member of Apache Cocoon
http://reflectingonthevicissitudes.wordpress.com/

Mime
View raw message