cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Giacomo Pati <giac...@apache.org>
Subject Re: pipelineComponent scope troubles
Date Tue, 18 Sep 2007 18:29:43 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1



Grzegorz Kossakowski wrote:
> Reinhard Poetz pisze:
>> Giacomo Pati wrote:
>>> Grzegorz Kossakowski wrote:
>>>
>>> To be honest, I get almost the same stack trace with your little sample.
> 
> Just to make sure: you have configured OM to be in request scope instead of pipelineComponent
scope?

Yes.

> I ask because my sample works (for me) following way:
> 1. If I have OM configured to be in pipelineComponent scope NPE is thrown and I get similar
stack
> trace to yours.

You can see the log at http://people.apache.org/~giacomo/GrekSample-pipelineComponent.log

> 2. BUT if I switch to request scope everything works fine and assuming there is no other
bug in my
> code it's all fine and expected.

Nope. Here not

You can see the log at http://people.apache.org/~giacomo/GrekSample-request.log

I've also verified, that the correct jar is take from my m2 repo in each case (compared the
size
with that one in the corresponding target directory).

Interestingly, I've also done a diff of these two log files and guess what, they are exactly
the
same ?!?!?!

I've also checked my cocoon trunk via 'svn st' but the only difference is the ObjectModel.xml.

I'm going to throw away my .m2, recompile it, and check your sample again. I just want to
be sure,
but this is going a little while.

Ciao and thanks

- --
Giacomo Pati
Otego AG, Switzerland - http://www.otego.com
Orixo, the XML business alliance - http://www.orixo.com

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.6 (GNU/Linux)

iD8DBQFG8BkXLNdJvZjjVZARAmckAJ9bLkhGWYZAkbxrobv5ad161uRjlACfVqrh
Ckjp9RjBlHwbeWA8N4qNk1I=
=iJUD
-----END PGP SIGNATURE-----

Mime
View raw message