cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reinhard Poetz <reinh...@apache.org>
Subject Re: pipelineComponent scope troubles
Date Tue, 18 Sep 2007 17:35:05 GMT
Grzegorz Kossakowski wrote:
> Reinhard Poetz pisze:
>> Giacomo Pati wrote:
>>> Grzegorz Kossakowski wrote:
>>> 
>>> To be honest, I get almost the same stack trace with your little sample.
> 
> Just to make sure: you have configured OM to be in request scope instead of
> pipelineComponent scope? I ask because my sample works (for me) following
> way: 1. If I have OM configured to be in pipelineComponent scope NPE is
> thrown and I get similar stack trace to yours. 2. BUT if I switch to request
> scope everything works fine and assuming there is no other bug in my code
> it's all fine and expected.

ok, request scope works for me.

>> Grek, your sample doesn't run for me either. From a quick glance I'd say 
>> that it's the same stacktrace as Giacomo posted.
> 
> See above.
> 
>> I also think that it's the same problem why the samples from trunk do not
>> run here.
> 
> I don't think so...
>
> I would be grateful if you all could take a little effort and understand how
> things work (by reading my e-mails carefully) so you would be better at
> reporting and less blaming at the same time.

sorry, I've read your mail but misunderstood it.

-- 
Reinhard Pötz           Independent Consultant, Trainer & (IT)-Coach

{Software Engineering, Open Source, Web Applications, Apache Cocoon}

                                        web(log): http://www.poetz.cc
--------------------------------------------------------------------

Mime
View raw message