cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reinhard Poetz <reinh...@apache.org>
Subject log4j 1.2.15 dependencies
Date Thu, 30 Aug 2007 21:08:14 GMT
Grzegorz Kossakowski wrote:
>>  Path to dependency:      1)
>> org.apache.cocoon:cocoon-spring-configurator:jar:1.0.1-SNAPSHOT
>>      2) log4j:log4j:jar:1.2.15
>>      3) javax.jms:jms:jar:1.1
> 
> Does anyone know why log4j has this dependencies introduced in minor version increase?

a quick guess: they indroduced Maven 2 recently and are not aware of the concept 
of scopes ...

> Since this dependencies are not on central repository, shouldn't they be defined as provided,
or so?

definitly, but it shouldn't be us to fix this in our pom. It's still a PITA that 
    dependencies are not checked if they really exist when things are deployed 
to the central repository.  *sigh*

Since we can probably leave out this release and wait for one with correct 
dependencies, I set the version of log4j to 1.2.14 again.

(BTW, great to have Continuuum running again!)

-- 
Reinhard Pötz           Independent Consultant, Trainer & (IT)-Coach 

{Software Engineering, Open Source, Web Applications, Apache Cocoon}

                                        web(log): http://www.poetz.cc
--------------------------------------------------------------------

Mime
View raw message