cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <joerg.heini...@gmx.de>
Subject Re: [jira] Commented: (COCOON-2110) Evaluate expressions defined in cocooon-expression-language-api in Sitemap engine
Date Mon, 13 Aug 2007 04:29:00 GMT
On 11.08.2007 6:23 Uhr, Alfred Nathaniel wrote:
> On Sat, 2007-08-11 at 11:22 +0200, Grzegorz Kossakowski wrote:

Thanks for the summary, Grek.

>> Speaking about myself I prefer much more language prefixes and I think we should
go for it. The 
>> question that we need to answer is if we want to support #{} syntax in sitemap? Since
it was never 
>> there I don't think it makes sense to do so.

Introducing #{} does indeed make no sense.

> The existing {input-module:parameter} syntax is flexible enough to support
> {jexl:cocoon.request.some_param} and {jxpath:cocoon/request/some_param},
> and that is not much harder to read or write than the ${} and #{}
> equivalents.

I wonder what exactly will it be when everything is unified: {} or ${}? 
I thought it's the latter, also the issue description seems to point on 
this.

Joerg

Mime
View raw message