cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carsten Ziegeler <cziege...@apache.org>
Subject Re: 2.2 does not build with JDK1.4.2
Date Wed, 11 Jul 2007 05:50:04 GMT
Hi,

did you try maven 2.0.7 with jdk 1.4.2?

While building Cocoon with 2.0.7 and jdk1.5, I noticed that the version
for the spring-dao was resolved to 2.0.4....which fortunately is
available :(

Carsten

Alfred Nathaniel wrote:
> There seems to be a Maven-intrinsic problem with building trunk using a
> 1.4.2 JVM.  With maven version 2.0.6 and the command line
> 
>   $ MAVEN_OPTS="-Xmx200m"
>   $ export MAVEN_OPTS
>   $ mvn -Dmaven.test.skip=true -P allblocks clean install
> 
> I get consistent build failures for cocoon-databases-impl
> 
>         [INFO] Failed to resolve artifact.
>         
>         Missing:
>         ----------
>         1) org.springframework:spring-dao:jar:2.4.1
>         
>           Try downloading the file manually from the project website.
>         
>           Then, install it using the command:
>               mvn install:install-file -DgroupId=org.springframework
>         -DartifactId=spring-dao \
>                   -Dversion=2.4.1 -Dpackaging=jar -Dfile=/path/to/file
>         
>           Path to dependency:
>                 1)
>         org.apache.cocoon:cocoon-databases-impl:jar:1.0.0-RC2-SNAPSHOT
>                 2) org.springframework:spring-jdbc:jar:2.0.6
>                 3) org.springframework:spring-dao:jar:2.4.1
>         
>         ----------
>         1 required artifact is missing.
>         
>         for artifact:
>           org.apache.cocoon:cocoon-databases-impl:jar:1.0.0-RC2-SNAPSHOT
> 
> The version number 2.4.1 for spring-dao is phoney, the latest version
> being 2.0.6.  The dependency in the spring-jdbc pom.xml is simply:
> 
>     <dependency>
>       <groupId>${project.groupId}</groupId>
>       <artifactId>spring-dao</artifactId>
>       <version>${project.version}</version>
>     </dependency>
> 
> This seems to be an incarnation of
> http://jira.codehaus.org/browse/MNG-2653
> 
> I see this with Sun JDK1.4.2_13 on Linux.  (Is it by chance that 2.4.1
> is 1.4.2 spelled backwards?)  With JDK1.5.0_09 the build runs through.
> 
> More fuel for the discussion on 1.4 vs 1.5 as minimum JVM for 2.2...
> 
> Cheers, Alfred.
> 
> 
> 
> 


-- 
Carsten Ziegeler
cziegeler@apache.org


Mime
View raw message