cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Grzegorz Kossakowski <gkossakow...@apache.org>
Subject Re: RT: map:call as generic non-redirecting controller code
Date Fri, 06 Jul 2007 11:36:34 GMT
Dev at weitling pisze:
> I'm not against processing data, I want to avoid introducing a new
> protocol. 

I think that we already have such a protocol, are you aware of xmodule:flow-attr combo?

> And functions returning values the classical way (return
> myBestStuff;) will reduce readability of the pipeline. For few and/or
> small values I'd prefer variables, for many and/or big values one should
> think about introduce a generator or transformer weaving the data
> directly into the pipeline.

By variables do you mean something like {someVar} construct in sitemap and someVar can only
contain string value?

> Giving even void functions a sense: Doing something when a certain point
> in a pipeline is reached not directly touching data flowing through the
> pipe.

That's what I would be against to. Side effects is the last thing we need in pipelines, IMHO.
Personally I would like to see possibility to 
call function only at the *beginning* of the pipeline and *before* data is even processed.
Exactly the same way actions are called today.

The point about implementing generator is valid only if you want to implement something generic
enough to call it component (generators are 
components). Implementing use-it-once components is anti-pattern, IMHO.

> Hope this was not even more obfuscating :-)

No, it clears your position a little. :-)

-- 
Grzegorz Kossakowski
http://reflectingonthevicissitudes.wordpress.com/

Mime
View raw message