cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Grzegorz Kossakowski <gkossakow...@apache.org>
Subject Re: svn commit: r552371 - trunk broken, help needed
Date Mon, 02 Jul 2007 10:40:05 GMT
Grzegorz Kossakowski pisze:
> Reinhard Poetz pisze:
>> I'm not sure if it is really a JDK issue. I guess that your setup got 
>> messed up by your refactorings. After fixing the compilation error 
>> (see my commit) I was able to run the cocoon-template-sample using the 
>> webapp produced by the rcl goal (I checked in the configuration) of 
>> the Cocoon Maven plugin with Java 5 (1.5.0_11) without a problem.
> 
> Sorry for compilation problem, I use Java 6 (1.6.0).
> 
>> Make sure that there are no old Java classes that haven't been deleted 
>> by SVN (run 'svn stat' on your working copy) and then run 'mvn clean'. 
>> As a next step I suggest that you remove all org.apache.cocoon 
>> artifacts from your local repository and finally run 'mvn install 
>> -Dmaven.test.skip=true'. This should make sure that your classpath 
>> doesn't contain any unwanted classes. HTH
> 
> I tried it few times, even checking classpath and I still get the same 
> error :(
> I'll try to downgrade my Java version or try it on another machine...

I have tried it on my second machine (openSUSE 10.2, Java 1.5.0_8) with clean installation
(no Maven repo, fresh cocoon checkout) and got 
exactly the same error.

Reinhard, could you give it another try? I'll try to reproduce it on Windows.

-- 
Grzegorz Kossakowski
http://reflectingonthevicissitudes.wordpress.com/

Mime
View raw message