cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antonio Gallardo <agalla...@agssa.net>
Subject Re: trunk broken?
Date Fri, 08 Jun 2007 10:15:43 GMT
Andrew Stevens escribió:
>> Date: Thu, 7 Jun 2007 22:37:02 +0200
>> From: danielf@nada.kth.se
>>
>> Antonio Gallardo skrev:
>>     
>>> Grzegorz Kossakowski escribió:
>>>       
>>>> Antonio Gallardo pisze:
>>>>         
>>>>> Grzegorz Kossakowski escribió:
>>>>>
>>>>> Am I missing something, but IIRC cocoon 2.2. should compile and run 
>>>>> with java 1.4. Is this correct?
>>>>>           
>>>> Yes, even though it seems that only few souls living in solitude use 
>>>> Java 1.4 these days...
>>>>         
>>> Not my case, I am already on 1.6. ;)
>>>
>>> I asked due the contract with our user base. Perhaps it is time to 
>>> reconsider this issue before the 2.2 release.
>>>       
>> For those not remembering, we are waiting for Joerg to retract his veto 
>> against switching to Java 1.5.
>>
>> In the meantime the benefit of supporting Java 1.4 decreases each day 
>> while the cost of doing so increases ...
>>
>> /Daniel
>>     
>
> Well, for what it's worth (which isn't much) I for one am glad Cocoon 2.2 still supports
JDK 1.4.  It's finally looking like our US datacentre is getting their act together so my
team can plan to migrate our sites off Websphere 5.0 (JDK 1.3, and end-of-life'd about 9 months
ago!) onto a more recent version.  However, the new version that they are willing to support
is 6.0, which uses... JDK 1.4
>   
In 2007 the company decided to upgrade to websphere 6.0. It is a product 
from 2004. Hence I don't believe such cutting-edge technology as cocoon 
2.2 is going to be picked up there until it is not 3 years old or so, 
hence we are talking about year 2010 when the company will plan to move 
to java 5 and cocoon 2.2. Is this correct? If yes, there is another 
reason to move to java 5 for cocoon 2.2 now! :)


> We're already being pressured to ditch Cocoon in favour of a proprietary in-house framework
(which would be a shame IMO as Cocoon is a much better fit with our XML-based content management
system).  Without 1.4 support, Cocoon becomes a dead end for us with no upgrade path, which
would make it harder to justify continuing with it.
>   
Minimal cocoon 2.1 requires java 1.3, but in fact you get more of it 
with java 1.4, some newer blocks requieres it as the minimal entry java 
version.

Best Regards,

Antonio Gallardo.

> I guess that makes us the few souls living in solitude :-)
>
>
> Andrew.
>   


Mime
View raw message