Hi,

On 7 Mar 2007, at 10:24, Bart Molenkamp wrote:

I've tried to build Cocoon with an empty local repository, block "Cocoon
Samples Style Default Block" has a dependency on cocoon-deployer-plugin
version 1.0.0-M2-SNAPSHOT which can't be found on any snapshot server.
This aftifact was available in my local repository.

Is the version in the pom incorrect?

I'm seeing the same problem. The cocoon-deployer-plugin version should be 1.0.0-SNAPSHOT afaict. But when Cocoon is built, you will end up with M2-SNAPSHOT in your repository!

Updating the pom.xml didn't fix it for me, for some reason I had to download it manually and install using:

mvn install:install-file -DgroupId=org.apache.cocoon -DartifactId=cocoon-deployer-plugin -Dversion=1.0.0-SNAPSHOT -Dpackaging=maven-plugin -Dfile=/path/to/cocoon-trunk/cocoon-deployer-plugin-1.0.0-SNAPSHOT.jar 

I had this problem on cocoon-apples-sample and cocoon-samples-style blocks.

It seems that the Cocoon build is not creating cocoon-deployer-plugin before some dependencies require it?

Thanks,

Andrew.
--
Andrew Savory, Managing Director, Sourcesense UK
Tel: +44 (0)870 741 6658  Fax: +44 (0)700 598 1135
Web: http://www.sourcesense.com/