cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Niels van Kampenhout <>
Subject Re: SERIOUS problems with 2.1.10 and rhino js-1.6R5
Date Tue, 29 May 2007 13:40:29 GMT
Robby Pelssers wrote:
> Porting our app from 2.1.8 to 2.1.10 resulted into SERIOUS problems. A 
> week of investigation told us that the loading behaviour of javascript 
> files, (we use cocoon.load a lot) is has an unpredictable performance. 
> Sometimes good and sometimes VERY bad
> In an earlier thread 
> <> Berry van 
> Halderen had a workaround for this by using a 1.6.R6pre  build of rhino. 
> We tried the same workaround but our scripts run into exceptions in 
> various places. It seems like methods in inner classes are not 
> accessible anymore. 
> Did we do something wrong when building rhino. We use JDK 1.5.0_09 and 
> changed the target in the rhino properties file to 1.5.
> Any ideas?

Do you happen to use importPackage(...) a lot? Try importing individual 
classes with importClass(...). Rhino seems to have classloader issues 
with importPackage, resulting in long loading times and unpredictable 

Hope this helps,

View raw message