cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jorg Heymans <jheym...@apache.org>
Subject Re: Exclusions does not work with dependency managment?
Date Tue, 01 May 2007 06:54:27 GMT
Grzegorz Kossakowski wrote:

> I also tried dependency plug-in already and had the same results as you. 
> It does not mention dependency we are talking about. I have no idea why.
> However, I'm almost sure. Try mvn eclipse:eclipse and import project. 
> You'll see avalon-framework-4.1.3.jar in build path added so it does 
> come from that module, doesn't it? Also, you'll see it while executing:
> mvn install -X
> 
> Can you verify my findings?

Unfortunately yes :(

[INFO] [eclipse:eclipse]
[DEBUG] org.apache.cocoon:cocoon-sitemap-impl:jar:1.0.0-RC1-SNAPSHOT 
(selected for null)
[DEBUG]   commons-collections:commons-collections:jar:3.2:compile 
(selected for compile)
[DEBUG]   commons-jxpath:commons-jxpath:jar:1.2:compile (selected for 
compile)
[DEBUG]     junit:junit:jar:3.8:compile (applying version: 3.8.2)
[DEBUG]     junit:junit:jar:3.8.2:compile (applying scope: test)
[DEBUG]     junit:junit:jar:3.8.2:test (selected for test)
[DEBUG]     xml-apis:xml-apis:jar:2.0.2:compile (applying version: 1.3.02)
[DEBUG]     xml-apis:xml-apis:jar:1.3.02:compile (selected for compile)
[DEBUG]     commons-logging:commons-logging:jar:1.0:compile (applying 
version: 1.1)
[DEBUG]     commons-logging:commons-logging:jar:1.1:compile (selected 
for compile)
[DEBUG]       log4j:log4j:jar:1.2.12:compile (applying version: 1.2.14)
[DEBUG]       log4j:log4j:jar:1.2.14:compile (selected for compile)
[DEBUG]       logkit:logkit:jar:1.0.1:compile (selected for compile)
[DEBUG]       avalon-framework:avalon-framework:jar:4.1.3:compile 
(selected for compile)
[DEBUG]       javax.servlet:servlet-api:jar:2.3:compile (applying 
version: 2.4)
[DEBUG]       javax.servlet:servlet-api:jar:2.4:compile (selected for 
compile)
[DEBUG]     commons-collections:commons-collections:jar:2.0:compile 
(applying version: 3.2)
[DEBUG]   javax.servlet:servlet-api:jar:2.4:provided (not setting scope 
to: compile; local scope provided wins)

It seems that the eclipse plugin is using some different (buggy) 
dependency resolution mechanism. Don't have time now to investigate 
further, will have another look later (perhaps its a confirmed bug in 
the plugin?)

rgds
Jorg




Mime
View raw message