cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reinhard Poetz <reinh...@apache.org>
Subject Re: building trunk.
Date Fri, 13 Apr 2007 13:49:57 GMT
Ralph Goers wrote:
> Giacomo Pati wrote:
>> I'v committed an initial dependencyManagement section in the root pom.
>>
>> The deps were gathered by concatenating all relevant poms into a big 
>> xml document and run through an
>> xsl stylesheet which extracted all dependencies sorting them by 
>> artifactId groupId. I've hand
>> crafted it afterwards to eliminate duplicates and put some TODOs into 
>> it for duplicate artifactIds
>> with different groups.
>>
>> Next step would be to eliminate all version element from the sub poms, 
>> right?
>>
>>   
> Yes, that is correct.  I knew we had smart people here - I wouldn't have 
> thought of doing it that way.  Thanks for the hard work!

thanks too :-)

As soon as the version numbers are removed, we have to make Maven 2.0.6 a 
prerequisite. IIRC this can be set in the root pom.

-- 
Reinhard Pötz           Independent Consultant, Trainer & (IT)-Coach 

{Software Engineering, Open Source, Web Applications, Apache Cocoon}

                                        web(log): http://www.poetz.cc
--------------------------------------------------------------------

Mime
View raw message