cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Savory <and...@luminas.co.uk>
Subject mvn archetype-block broken?
Date Mon, 30 Apr 2007 13:59:35 GMT
Hi,

The block archetype seems to have problems with missing versions on  
dependencies now:

Project ID: com.mycompany:myBlock1
POM Location: getting-started-app/myBlock1/pom.xml
Validation Messages:

     [0]  'dependencies.dependency.version' is missing for  
org.apache.cocoon:cocoon-core
     [1]  'dependencies.dependency.version' is missing for  
org.apache.cocoon:cocoon-servlet-service-components
     [2]  'dependencies.dependency.version' is missing for  
org.apache.cocoon:cocoon-template-impl


Reason: Failed to validate POM


Editing the pom to include e.g. for cocoon-core <version>2.2.0-RC1- 
SNAPSHOT</version> seems to fix it ... but is this an intended change?



Thanks,

Andrew.
--
Andrew Savory, Managing Director, Sourcesense UK
Tel: +44 (0)870 741 6658  Fax: +44 (0)700 598 1135
Web: http://www.sourcesense.com/



Mime
View raw message