cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Grzegorz Kossakowski (JIRA)" <j...@apache.org>
Subject [jira] Closed: (COCOON-1975) cocoon-core-M2 could not be runned because of missing dependencies on avalon-framework-api-4.3 and excalibur-instrument-api-2.1
Date Mon, 30 Apr 2007 08:31:15 GMT

     [ https://issues.apache.org/jira/browse/COCOON-1975?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Grzegorz Kossakowski closed COCOON-1975.
----------------------------------------

       Resolution: Fixed
    Fix Version/s: 2.2-dev (Current SVN)
         Assignee: Grzegorz Kossakowski  (was: Reinhard Poetz)

It seems that we are no longer affected by this issue (with workarounds, though) so I close
it for now.

> cocoon-core-M2 could not be runned because of missing dependencies on avalon-framework-api-4.3
and excalibur-instrument-api-2.1
> -------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: COCOON-1975
>                 URL: https://issues.apache.org/jira/browse/COCOON-1975
>             Project: Cocoon
>          Issue Type: Bug
>          Components: - Build System: Maven
>    Affects Versions: 2.2-dev (Current SVN)
>            Reporter: Grzegorz Kossakowski
>         Assigned To: Grzegorz Kossakowski
>            Priority: Blocker
>             Fix For: 2.2-dev (Current SVN)
>
>
> Using clean (empty ~/.m2/repository directory) maven instalation it is not possible to
try cocoon-core-M2 following this tutorial: http://cocoon.zones.apache.org/daisy/documentation/g1/1159.html
(really BIG thanks goes to Reinhard Pötz for improving docs last days!). It's due to somehow
missing (or badly resovled) on avalon-framework-api-4.3 and excalibur-instrument-api-2.1 and
results in error I've reported earlier:
> http://article.gmane.org/gmane.text.xml.cocoon.devel/68960
> If I copy manully missing jars into myWebapp/target/myWebapp-1.0-SNAPSHOT/WEB-INF/lib
and start myWebapp using:
> mvn package jetty:run everything works as expected.
> On other hand, if you build whole trunk and install all blocks into local repository
dependencies are resolved correctly.
> I'm trying to investigate futher but any help would be desired as I'm not Maven nor Cocoon
expert :)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message