cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Savory <and...@luminas.co.uk>
Subject 2.2 failing to build: cocoon-javaflow
Date Mon, 16 Apr 2007 10:14:21 GMT
Hi,

Trying to do a clean build of C2.2 I'm seeing errors building cocoon- 
javaflow because of a missing org.apache.commons:commons-jci-core:jar: 
1.0-RC1.

jci-core 1.0-SNAPSHOT seems to be commented out of cocoon-core. The  
below fixes it and allows c2.2 to build, but as I don't know what it  
does I'm reluctant to just commit. Can anyone comment?

Also, I'm slightly mystified that I seem to be the only one hitting  
this. Is no-one else building 2.2? Am I doing something different to  
everyone else? Why isn't continuum [1] picking this up? (Oh, and how  
do I get a continuum login?)


svn diff core/cocoon-core/pom.xml
Index: core/cocoon-core/pom.xml
===================================================================
--- core/cocoon-core/pom.xml    (revision 529180)
+++ core/cocoon-core/pom.xml    (working copy)
@@ -195,11 +195,12 @@
        <artifactId>commons-io</artifactId>
        <version>1.3.1</version>
      </dependency>
-    <!--dependency>
+    <dependency>
        <groupId>org.apache.commons</groupId>
        <artifactId>commons-jci-core</artifactId>
-      <version>1.0-SNAPSHOT</version>
+      <version>1.0-RC1</version>
      </dependency>
+    <!--
      <dependency>
        <groupId>jakarta-bcel</groupId>
        <artifactId>jakarta-bcel</artifactId>


[1] http://cocoon.zones.apache.org/continuum/servlet/continuum


Thanks,

Andrew.
--
Andrew Savory, Managing Director, Sourcesense UK
Tel: +44 (0)870 741 6658  Fax: +44 (0)700 598 1135
Web: http://www.sourcesense.com/



Mime
View raw message