cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reinhard Poetz <reinh...@apache.org>
Subject Re: Reloading the mountableServlets map in DispatcherServlet
Date Sat, 24 Mar 2007 12:33:14 GMT
Grzegorz Kossakowski wrote:
> Reinhard Poetz napisał(a):
>> Grzegorz Kossakowski wrote:
>>
>> Grek,
>>
>> I've had some time today and found the reason why the rcl doesn't work
>> for you. You are using cocoon-servlet-service-impl-1.0.0-M1 and not
>> the latest version from SVN that I had to fix in order to get Spring
>> context objects reloaded.
>>
>> While Carsten and I were walking through the code, he also changed
>> things in the cocoon-core modules but I'm sure if this was really
>> necessary to get the rcl stuff working.
>>
>> The best way to test the RCL stuff is trying it out in
>> cocoon-rcl-plugin-demo.
> I'm ashamed. cocoon-rcl-plugin-demo works perfectly on Linux with Java6.
> After correcting the dependencies, block created from archetype works
> too. I could even add new methods and use them :)
> I'm really sorry for wasting your time :-/

no problem :-)

> Now, I would like to ask you for opinion on what should we do in order
> to avoid similar situations. Should docs of cocoon-rcl be changed
> explaining what are the correct dependencies? Or should correct them in
> archetypes? Or both? :)

As soon as we release the modules, the problem will be gone. I've also updated 
the docs with a comment saying that one has to use latest 
cocoon-servlet-service-impl.

-- 
Reinhard Pötz           Independent Consultant, Trainer & (IT)-Coach 

{Software Engineering, Open Source, Web Applications, Apache Cocoon}

                                        web(log): http://www.poetz.cc
--------------------------------------------------------------------

Mime
View raw message