cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bart Molenkamp" <b.molenk...@bizzdesign.nl>
Subject RE: [2.2] cocoon-batik-impl block compiles against parts of batik 1.5 (again), should be 1.6-1
Date Mon, 05 Feb 2007 08:16:49 GMT
I submitted a patch:
https://issues.apache.org/jira/browse/COCOON-2003

Bart.

> -----Oorspronkelijk bericht-----
> Van: Bart Molenkamp
> Verzonden: vrijdag 2 februari 2007 16:19
> Aan: dev@cocoon.apache.org
> Onderwerp: [2.2] cocoon-batik-impl block compiles against parts of
batik 1.5 (again), should be
> 1.6-1
> 
> Hi,
> 
> I reported this problem earlier, spotted the error in the pom and a
fix
> was applied to it. Now I found the same problem again.
> 
> The block cocoon-batik-impl compiles sources against batik-1.5-fop
> 0.20.5, while the rest of batik is version 1.6-1. This breaks the
block,
> because the signature of HashTableStack.put has changed (and isn't
> compatible anymore). See [1].
> 
> Now, the dependency batik-transcoder includes the (wrong)
batik-1.5-fop
> as well. Could someone add the same exclusion that is added to the
> batik-squiggle dependency to the batik-transcoder dependency as well?
> The exclusion is needed in both the batik-transcoder as in
> batik-squiggle (which requires the transcoder).
> 
> I can provide a patch, but maybe it's simpler for someone with write
> access to copy-paste the exclusion snippet. If I need to provide a
> patch, please let me now.
> 
> Thanks,
> Bart.
> 
> [1] http://www.mail-archive.com/dev@cocoon.apache.org/msg48624.html


Mime
View raw message