cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Philipp Zerelles <phil...@moongate.de>
Subject Re: Bugs in CForms with flowscript or javaflow
Date Fri, 02 Feb 2007 18:27:57 GMT
I forgot, I am running Cocoon 2.2 trunk.

On Friday 02 February 2007 19:23, Philipp Zerelles wrote:
> 1. I have a portal here using the portal block and several forms running as coplets.
> When I run the flowscript debugger, I see that all of my form scripts are started twice
when activating the form. 
> I thought that it's maybe a debugger flaw, but now I have database access in my flowscript
and that is executed two times as well when I start one form.
> 
> 2. I then tried to switch to javaflow. The database access I mentioned is done using
Hibernate configured through spring configuration files only. 
> This works great in flowscript, where I can just call cocoon.getComponent(...) to get
my configured beans.
> But when I try the same in javaflow, getComponent(...) of the same beans fails with an
exception about the beans not being known.
> 
> My project consists of two blocks, one containing the webapp, the other the portal application.

> My beans are configured in the COB-INF/config/spring directory of my portal block. Are
there more than one spring bean factory used in cocoon? 
> Maybe one for each block and the flowscript uses the block's factory and javaflow uses
the webapps factory? Any ideas?
> 
> Thanks,
> Philipp Zerelles
> 

Mime
View raw message