cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reinhard Poetz <reinh...@apache.org>
Subject Re: [jira] Commented: (COCOON-1975) cocoon-core-M2 could not be runned because of missing dependencies on avalon-framework-api-4.3 and excalibur-instrument-api-2.1
Date Wed, 03 Jan 2007 23:08:50 GMT
Grzegorz Kossakowski wrote:
> Reinhard Poetz napisał(a):
>> I can reproduce this, today. I could swear that it worked when I cut 
>> the release two weeks ago also with an empty local repository.
>>
>> Any idea what's going on here?
> 
> After reading debug log of Maven I can describe what happens partly:
> In some parent poms (like cocoon's root pom) there is declaration of 
> apache.snapshot repository where avalon stuff is stored in. For some 
> reason when it comes that Maven should get pom of 
> avalon-framework-impl-4.3 it "forgets" about apache.snapshot and checks 
> only central. 

avalon-framework-impl is also available at central 
(http://repo1.maven.org/maven2/avalon-framework/avalon-framework-impl/4.3/avalon-framework-impl-4.3.pom)

and has a dependency on avalon-framework-api or is this something different?


-- 
Reinhard Pötz           Independent Consultant, Trainer & (IT)-Coach 

{Software Engineering, Open Source, Web Applications, Apache Cocoon}

                                        web(log): http://www.poetz.cc
--------------------------------------------------------------------

Mime
View raw message