cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Lundquist ...@wrinkledog.com>
Subject Re: RCL difficulties (was Re: Input modules samples broken in trunk)
Date Thu, 11 Jan 2007 15:49:50 GMT

On Jan 10, 2007, at 10:20 PM, Reinhard Poetz wrote:

>> I just tried setting up the RCL per 
>> http://cocoon.zones.apache.org/daisy/cdocs/g1/g4/g1/1297.html; is 
>> that the solution I'm after?
>> I added the rcl.properties to cocoon-core-addition-sample/pom.xml and 
>> tweaked the cocoon-webapp/pom.xml, ran "mvn rcl:webapp" there...  but 
>> when I request the webapp site root in my browser, I get:
>> Looking at target/rcl/webapp, I see that there's a WEB-INF/ there, 
>> but that's all.... the sitemap.xmap etc., are all missing.
>
>
> After running rcl:webapp, have you tried to start the created webapp?

Yes, I'm sorry, I see where in my original email I left a place to 
paste in the reply from Cocoon, but then I forget to do it.  Here's 
what I see in the browser:

========================================
	HTTP ERROR: 503

	SERVICE_UNAVAILABLE
	RequestURI=/

	Powered by jetty://
========================================

> There is no need for a global sitemap.xmap anymore. You mount one of 
> your blocks to the root of your webapp ("/").

No, no... this is core/cocoon-webapp where I have done this.  I did it 
there, in situ, just temporarily while I (hopefully) test some changes 
in trunk. cocoon-webapp does have "global" (self-contained root-level) 
resources (sitemap.xmap, welcome.xml, stylesheets/ etc.).

I know how to do it the block way, that's not the issue... I'm just 
trying to quick-'n'-dirty configure my own local build of cocoon-webapp 
to use the RCL, and it doesn't appear to be working right — which is 
probably All My Fault somewhere, and I'm trying to figure out where I 
went wrong :-).

target/rcl/webapp/ should (I presume) end up containing everything that 
target/webapp does, right?  My target/rcl/webapp contains only the 
WEB-INF, but nothing else.

Any ideas?

—ml—


Mime
View raw message