cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary Larsen" <gary.lar...@envisn.com>
Subject RE: Continuation exception - 2.1.10 upgrade
Date Thu, 25 Jan 2007 17:56:12 GMT
> We also spent 2 days trying to fix it inside the rhino code. 
> Our work around after 2 days was to continue using 
> rhino1.5r4-continuations-R26.jar. The latest cocoon 
> revision using the 
> later jar on subversion is 479984.
 
When I extracted this revision it looks like Tortoise extracted the trunk
version of the blocks so I get compile errors:

cocoon-block-forms-compile:
Compiling 380 source files to
C:\development\envisn\cocoon-2.1.10.479984\build\c
ocoon\blocks\forms\dest
C:\development\envisn\cocoon-2.1.10.479984\src\blocks\forms\java\org\apache\
coco
on\forms\util\JavaScriptHelper.java:63:
compileReader(org.mozilla.javascript.Scr
iptable,java.io.Reader,java.lang.String,int,java.lang.Object) in
org.mozilla.jav
ascript.Context cannot be applied to
(java.io.StringReader,java.lang.String,int,
<nulltype>)
            script = ctx.compileReader(new StringReader(jsText), // in
 
I guess I'll try 2.1.9 unless there is an easy way to get a revision where
the blocks work also.

Gary



Mime
View raw message