cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stewart, Gary" <Gary.Stew...@luht.scot.nhs.uk>
Subject RE: Looking for help in upcoming release
Date Fri, 15 Dec 2006 16:48:07 GMT
> -----Original Message-----
> From: Carsten Ziegeler [mailto:cziegeler@apache.org]
> Sent: 11 December 2006 13:56
> To: Cocoon-Dev; Cocoon-Users
> Subject: Looking for help in upcoming release
> 
> 
> Hi community,
> 
> the Cocoon project is working very hard to release 2.1.10 by Monday,
> December 18th.
> 
> To meet this goal -- which clearly will benefit all users -- we need
> some *specific* QA (quality assurance) input from the user community.
> While we believe that the current development version of 2.1.10 is
> stable, we would like to prove this by our users.
> 

Sorry that is so late given the Monday timescale.

Version info:

Revision: 487548
java version "1.5.0_04"
Windows 2000 with Service Pack 4

The build was fine. Starting up cocoon using JeTTY got some warnings:

WARN! *** JMS block is installed but jms client library not found. ***
- For the jms block to work you must install and start a JMS server and place th
e client jar in WEB-INF/lib.
- The default server, OpenJMS is configured in cocoon.xconf but is not bundled w
ith Cocoon.

That's to be expected as I didn't download OpenJMS.

During the tests I had:

Hello World Tests
=================

http://localhost:8888/samples/hello-world/hello.sxi

return:

org.xml.sax.SAXParseException: Invalid byte 3 of 3-byte UTF-8 sequence.
file:/C:/cocoon/cocoon-2.1.10/build/webapp/samples/hello-world/style/xsl/page2sxi.xsl - 107:78

and 

http://localhost:8888/samples/hello-world/hello.sxd

return:

org.xml.sax.SAXParseException: Invalid byte 3 of 3-byte UTF-8 sequence.
file:/C:/cocoon/cocoon-2.1.10/build/webapp/samples/hello-world/style/xsl/page2sxd.xsl - 68:78

I didn't open all the links like WML (the fact they returned a file for download made me happy
that they worked :) ). Everything else was fine in that group.

Aggregation
===========

The Slashdot Feed in the aggregation section didn't seem to work but that seems to be because
my work "abuses" the feed :D. So it appears as a plain text message (I consider that a pass).

Loop Inclusion correctly returned an error page.

Catalogs and DocBook
====================

I didn't follow the configuration steps and got file not found errors for both Entity Resolution
With Catalogs and DocBook Demo.

The Power of Sitemap: Input Modules 
===================================

Got a not found for http://localhost:8888/docs/userdocs/concepts/modules.html specifically:

java.io.FileNotFoundException: C:\cocoon\cocoon-2.1.10\build\webapp\docs\sitemap.xmap (The
system cannot find the path specified)

likewise with http://localhost:8888/api/java/org/apache/cocoon/components/modules/input/package-summary.html

C:\cocoon\cocoon-2.1.10\build\webapp\api\java\org\apache\cocoon\components\modules\input\package-summary.html
(The system cannot find the path specified)

Other Cocoon Flow Samples
=========================

Really minor: has "Back - to Cocoon Blocks Samples main page" when it isn't actually linked
from that page anymore.

Blocks
======

Chaperon: 
---------

Example 1 - The parser can also be used to colorize some source code. 

Seems to point to a fixed location

java.io.FileNotFoundException: http://svn.apache.org/viewvc/*checkout*/cocoon-2.1/src/java/org/apache/cocoon/Cocoon.java

likewise with Example 2

java.io.FileNotFoundException: http://svn.apache.org/viewvc/*checkout*/cocoon-2.1/src/java/org/apache/cocoon/Cocoon.java

For databases it comments "The default installation of Apache Cocoon does not allow uploads.
This feature needs to be enabled in web.xml" whereas it allowed uploads on all the upload
components without changing the default web.xml

Forms
-----

The Capatcha form didn't work in the Forms example (it didn't show the string) and the Batik
Block seemed to be working ok.
Profiling information form1 - JXTemplate produced

org.apache.cocoon.forms.FormsRuntimeException: The template cannot find a form object
<jx:set> - resource://org/apache/cocoon/forms/generation/jx-macros.xml - 49:117



HTML Block Samples
------------------

Cocoon News seemed to only produce the title (could be a proxy thing).

JSP Block
---------

Returned error but does mention it requires configuration.

Lucene Block
------------

After creating the index it the search page appeared but I couldn't seem to get any results.
Didn't spend any more time on it.

OJB Block Samples
-----------------

Skipped!

Web3 Block
----------

Didn't configure this ;).

XMLDB Block Samples
-------------------

Got org.apache.xindice.core.DBException: Collection 'db' cannot store resources (no filer)
from Mount DB and had bad requests from Query Collection and Query Resource. 

XSP Block Samples
-----------------

Didn't install python so those tests skipped and proxy stopped the soap servers being reached
(seemed to handle the timeout fine though).

ASCII Art Block Samples
-----------------------

ASCII Art 10 to JPEG and PNG gave a heap space error. Could have increased the default heap
but I didn't :D.

Capatcha
--------

Examples here work fine. External link http://cocoon.zones.apache.org/daisy/documentation/blocks/captcha.html
and http://cocoon.zones.apache.org/daisy/documentation/components/readers/captchareader.html
are not found.

Image Effects Samples
---------------------

Image grayscaled gets java.lang.IllegalArgumentException: Source or Destination ColorSpace
is undefined
As mentioned the transforms don't work :) but do get you to a nice black image.

JMS Examples
------------

Didn't work for me but then I didn't have it installed as mentioned above ;).

Mail Block Samples
------------------

Skipped.

Petstore Block
--------------

Error org.mozilla.javascript.JavaScriptException: java.sql.SQLException: Table not found in
statement [select * from CATEGORY]
don't know if I need to do something to configure this.

Proxy Block Samples
-------------------

on Virtual Portal Demo: java.net.ConnectException: Connection timed out: connect again due
to local proxy settings not being on the Jetty server and allowing these sites to be reached.

QDoxSource Block Samples
------------------------

Skipped due to not configuring it.

Query Bean
----------

Skipped as I don't have the docs (as far as I know and the index creation seemed to confirm
that).

Slide Block
-----------

Skipped.

WebDAV Block Samples
--------------------

Again didn't configure this :-|.

All the other test not mentioned worked fine (the Error handling ones all produced, as far
as I could see, the correct errors including the redirect to empty functions, validation etc.).
The docs didn't work but I didn't include them in the build so that was to be expected.

All in all, looks good.

Hope this helps,

Gary






*****************************************************************
The information contained in this message may be confidential or 
legally privileged and is intended for the addressee only. If you 
have received this message in error or there are any problems 
please notify the originator immediately. The unauthorised use, 
disclosure, copying or alteration of this message is 
strictly forbidden.
*****************************************************************


Mime
View raw message