cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antonio Gallardo <agalla...@agssa.net>
Subject Re: [VOTE] Drop JDK1.3 support after 2.1.10 release
Date Mon, 18 Dec 2006 07:36:52 GMT
Bertrand Delacretaz escribió:
> On 12/18/06, Niclas Hedhman <niclas@hedhman.org> wrote:
>
>> ...I would be voting -1 in behalf of unheard users....
>
> The unheard users who need 1.3 compatibility would be very welcome to
> contribute to the effort.
>
> We don't seem to have an active "1.3 support" team ATM, so the best
> intentions will bring us nowhere unless someone steps up and actually
> *does the work* needed to make it happen.
Hi,

At the same time, I see this situation is going to be repeated in the 
future for cocoon 2.2. I think we should re-think again the minimum java 
requirement for cocoon 2.2.

Because now java 1.6 is out, java 1.4 is going to be enter in his EOL 
soon and java 1.3 is now officially dead. We should set java 1.5 as the 
entry java version for cocoon 2.2 to avoid repeat this situation again. 
wdyt?

As you know I worked actively on java 1.3 support, only because we had a 
contract with our users base and not because I was using java 1.3 at 
all. I stopped to update some libraries in cocoon 2.1, because they 
migrated to java 1.4. in some cases, I tried to make them work by 
recompiling for java 1.3, few cases were succesful, but often was not 
the case.

Currently, I could not work on java 1.3 support, because:

1) Lack of time: my 5.5 months-old Benjamin requires a lot of time.
2) My OS does not support java 1.3 at all. Fedora Core 6 dropped a 
compatibility library needed to run java 1.3: libstdc++-libc6.1-1.so.2. 
This library used to be on compat-libstdc++-296 package. Now every 
attempt to run java 1.3 ends in a missing shared library error.

... wait, IIRC, we can use the source and target compiler flags in ant 
to point to 1.3, right? Hence we could check compile for 1.3 even if we 
are running java 5 or so. The only problem is this way we can only tell 
it *compiles* in java 1.3 but not assure it runs in java 1.3. I am puzzled!

Anyone can take the task?

>
> (repeating myself a bit here, but things don't seem to have changed
> since last week)

Seems like all us is too busy. :)

Best Regards,

Antonio Gallardo.


Mime
View raw message