cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Philipp Zerelles <phil...@moongate.de>
Subject Re: Trunk broken?
Date Thu, 28 Dec 2006 17:48:26 GMT
Well, I created the eclipse project using "mvn eclipse:eclipse". Then I 
imported it into my workspace (btw, I ony use the webapp now with the 
SitemapServlet) and configured the Jetty Launcher to use my Jetty 5.1.12 
installation (that defaults to Servlet 2.4, too) and set the webapp root 
to "src/main/webapp". My webapp contains a web.xml file that is set to use 
2.4 Servlets.

Then I start to debug, jetty starts and I get the error message when 
accessing "/".

On Thursday 28 December 2006 18:25, Reinhard Poetz wrote:
> Philipp Zerelles wrote:
> > I just created a new webapp and block using the archetypes from trunk and
> > I get the same error when using the Jetty-Eclipse-Plugin to run the
> > webapp:
> >
> > java.lang.IllegalStateException: No thread-bound request found: Are you
> > referring to request attributes outside of an actual web request? If you
> > are actually operating within a web request and still receive this
> > message,your code is probably running outside of
> > DispatcherServlet/DispatcherPortlet: In this case, use
> > RequestContextListener or RequestContextFilter to expose the current
> > request.
> >
> > When I run it using maven, it works without problem. Any idea why it does
> > not work with eclipse?
>
> Are you sure that the web.xml, that is used, contains the listener (or
> filter) and is set to version 2.4 as suggested by Jörg and Carsten?

Mime
View raw message