cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremy Quinn <jer...@apache.org>
Subject Re: Building changes into the top level sitemap
Date Tue, 05 Dec 2006 17:38:24 GMT
OK, so even though I could not get $ mvn package to run inside the  
dists/cocoon-dist-samples, I found that the changes to the top-level  
sitemap from core/cocoon-webapp/ had in fact been added to the  
sitemap at : dists/cocoon-dist-samples/target/cocoon-samples/ 
sitemap.xmap

I was able to start Jetty in : dists/cocoon-dist-samples

When I went to http://localhost:8888/_cocoon/system/ajax/upload/ 
status I get this error :

java.io.FileNotFoundException: Could not open ServletContext resource  
[/resource://org/apache/cocoon/ajax/system/sitemap.xmap]

Why should it say "/resource://" ? (the leading slash is not in the  
sitemap.)

Doing a $ jar -tf dists/cocoon-dist-samples/target/cocoon-samples/WEB- 
INF/lib/cocoon-ajax-impl-1.0.0-M2-SNAPSHOT.jar

I see all of the new stuff that is needed :

. . .
org/apache/cocoon/ajax/system/i18n/messages.xml
org/apache/cocoon/ajax/system/sitemap.xmap
org/apache/cocoon/ajax/system/System.JSON.js
org/apache/cocoon/ajax/system/System.Upload.js
. . .

Am I looking in the right place?

Thanks

regards Jeremy

On 5 Dec 2006, at 17:08, Jeremy Quinn wrote:

> On 5 Dec 2006, at 13:42, Giacomo Pati wrote:
>
>> -----BEGIN PGP SIGNED MESSAGE-----
>> Hash: SHA1
>>
>>
>>
>> Jeremy Quinn wrote:
>>
>>> I have tried to compile this in, but it never becomes available  
>>> to the
>>> samples.
>>>
>>> I tried running $ mvn package in both :
>>
>> You probably have to use 'mvn install' as 'mvn package' only build  
>> the jar in you target folder of
>> the block whareas you'll need it to be installed into your local  
>> repository so other parts of the
>> build system can take them from there.
>
> Ever since I ran $ mvn install in core/cocoon-webapp/, I cannot get  
> $ mvn package to work in dists/cocoon-dist-samples/.
>
> No matter how many times I run it (I also went back and did a  
> complete clean install from root) I get this from the build :


Mime
View raw message