cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alfred Nathaniel <a.nathan...@bluewin.ch>
Subject [VOTE] Drop JDK1.3 support after 2.1.10 release
Date Wed, 13 Dec 2006 23:55:38 GMT
The current mantra is that Cocoon 2.1 is JDK1.3+ compatible and only
from Cocoon 2.2 onwards JDK1.4+ is required.

However, nowadays all developers use 1.4, or 5.0, or soon even 6.0.
That makes it tedious to guarantee 1.3 support because Java compilers
allow to set source file compatibility but they do not check API
versions.  (For example, RuntimeException(String, Throwable) is a 1.4
addition.)

This errors are usually easy to fix but always leave a bad taste of
unkept promisses when they go unnoticed by committers and are pointed
out by users.

I therefore propose to declare 2.1.10 the last release with JDK1.3
compatibility.

In case there are really any JDK1.3 locked-in users who deploy 2.1.10
and find showstopper bugs, we create a BRANCH_2_1_10_X where point
patches can be applied.  That may possibly lead to a consolidated
2.1.10.1 maintenance release.

Please cast your votes.

Here is my +1.

Cheers, Alfred.


Mime
View raw message