cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luca Morandini <lmorand...@ieee.org>
Subject Re: Trying to start Cocoon 2.2
Date Wed, 29 Nov 2006 09:52:43 GMT
Daniel Fagerstrom wrote:
> Luca Morandini skrev:
>> Reinhard Poetz wrote:
>>> Daniel Fagerstrom wrote:
>>>> Luca Morandini skrev:
>>>> We have updated the deployment mechanism recently, and I got the 
>>>> same error message a short period before I updated the bean 
>>>> configuration in 
>>>> META-INF/cocoon/spring/cocoon-core-main-sample-blockServlet.xml for 
>>>> cocoon-core-main-sample. 
>>>
>>> Luca (and others), delete your org/apache/cocoon directory from your 
>>> local repo and build cocoon again. Maybe this helps ...
>>
>> Unfortunately it doesn't.
>>
>> So, I updated the SVN working copy, deleted the whole cocoon branch of 
>> the maven repo, executed a clean build and yet I cannot make Cocoon 
>> run... despiriting indeed.
> 
> Sounds frustrating :/
> 
> I followed exactly the same steps as you have described in your mails, 
> and for me it works.
> 
> I assume that you get the same errors as before? In that case something 
> is wrong with your Maven setup. The cocoon-webapp module doesn't depend 
> on cocoon-core-main-sample anymore, so the fact that it shows in your 
> stack trace means that it is not the poms from your newly updated Cocoon 
> that is used. Probably some old poms and maybe also some old jars are 
> downloaded during the build process. Also the error messages looks like 
> problems that I and others have fixed some while ago. Which also is a 
> reason to believe that some older versions of the jars are downloaded 
> and executed.

Dropped the Maven local repository and re-ran the build: no hope.


> Jorg wrote some while ago that there can be problems with some settings 
> file pointing to mirrors with artifacts that are not synchronized 
> properly 
> http://marc.theaimsgroup.com/?l=xml-cocoon-dev&m=116404436302770&w=2. 
> You could see if his suggestions help.

Dropped settings.xml and svn-updated to recreate it: no joy.


> Otherwise you need to figure out why cocoon-core-main-sample becomes 
> part of your cocoon-webapp during build. If you rebuild cocoon-webapp 
> using the -X switch you will get a complete tree view of all the 
> dependencies. So here we would need to know the dependency chain for the 
> cocoon-core-main-sample jar.

Dropped (again) the local maven repository, dropped the cocoon-2.2 
checkout, did a fresh checkout... and Cocoon eventually worked.

But I suppose is not meant to be this way...

Regards,

--------------------
    Luca Morandini
www.lucamorandini.it
--------------------


Mime
View raw message