cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Klimetschek <alexander.klimetsc...@mindquarry.com>
Subject Re: Run Cocoon without deployer
Date Thu, 16 Nov 2006 16:44:45 GMT
Looks like my webapp configuration does not fit with the new deploying 
mechanism. I just copied the new cocoon.xconf in my WEB-INF/cocoon/ dir, 
thinking that the source factory config was not loaded correctly, but 
this did not help either.

So what else is needed to use the new configuration apart from having 
META-INF/cocoon/(avalon|spring) directories in my block? Do I still need 
to run the cocoon:deploy? What is the minimum requirement for my webapp 
module that contains the src/main/webapp/WEB-INF directory with my own 
web.xml?

Sorry if this was posted on this mailing list already, but I don't find 
the right information in those long threads discussing the dir structure 
etc. ;-)

Alex

Alexander Klimetschek schrieb:
> Reinhard Poetz schrieb:
>> Alexander Klimetschek wrote:
>>> Daniel Fagerstrom schrieb:
>>>> blockcontext:/blockname/ - resolves to a file source that contain 
>>>> the COB-INF directory of the block.
>>>
>>> What is the blockname? I tried the name of the directory (like 
>>> previously in /blocks/my-block/ => my-block), a name="my-block" in 
>>> the bean and the id of the bean as blockname, but all did not work.
>>
>> have you tried the name set in the manifest?
>>
> 
> I have debugged the problem and found that the blockcontext 
> Sourcefactory cannot be looked up in the Avalon ServiceManager. I have a 
> fresh new install of cocoon 2.2 trunk.
> 
> Alex
> 


-- 
Alexander Klimetschek
http://www.mindquarry.com


Mime
View raw message