cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Fagerstrom <dani...@nada.kth.se>
Subject Re: Trying to start Cocoon 2.2
Date Tue, 28 Nov 2006 08:34:17 GMT
vepeter skrev:
> Hi, all,
>
> I try to get started with cocoon 2.2
> I got it built with "mvn -Dmaven.test.skip=true -Dmaven.war.shieldingclassloader=false
clean install"
> ant run with "mvn jetty:run -Dorg.apache.cocoon.mode=dev"
>
> But when I try to request any page I have the following error on the
> response page:
>
> Message: javax.xml.transform.dom.DOMResult.getNextSibling()Lorg/w3c/dom/Node;
>
> Description: org.springframework.beans.factory.BeanDefinitionStoreException:
> Unexpected exception parsing XML document from resource loaded from
> byte array; nested exception is java.lang.NoSuchMethodError:
> javax.xml.transform.dom.DOMResult.getNextSibling()Lorg/w3c/dom/Node;
>
> Sender: org.apache.cocoon.servlet.RequestProcessor
>
> Source: Cocoon Servlet
>
> Request URI
>
> cause
>
> java.lang.NoSuchMethodError: javax.xml.transform.dom.DOMResult.getNextSibling()Lorg/w3c/dom/Node;
>
> request-uri
>
> /
>   
I don't know exactly how to solve it but you might get some insight from 
the previous thread 
http://www.mail-archive.com/dev@cocoon.apache.org/msg47740.html. The 
lacking method is part of Java 5 but not Java 1.4. Cocoon has a 
dependency on  xml-apis-1.3.02.jar that contains the right version of 
javax.xml.transform. So probably an older version of the library shadows 
the right one in you classpath. Use the -X switch to jetty:run to see 
what classpath you use. It might be that it is the one from Java 1.4, in 
that case you could try to use the shielding classloader, it works for 
some people.

/Daniel


Mime
View raw message