cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Fagerstrom <dani...@nada.kth.se>
Subject Re: getting started with 2.2
Date Tue, 21 Nov 2006 22:00:44 GMT
Daniel Fagerstrom skrev:
> Mark Lundquist skrev:
>>
>> On Nov 21, 2006, at 12:21 PM, Daniel Fagerstrom wrote:
>>
>>> Testing again, it happens to me also when I do a "mvn package" after 
>>> a "mvn clean", if I do a second "mvn package" it works.
>>
>> Yes, OK... the second time worked.
>>
>> Now then, how do I run the webapp?  "mvn jetty:run" invoked from 
>> cocoon-dist-samples yields
>>
>>     [INFO] The plugin 'org.apache.maven.plugins:maven-jetty-plugin' 
>> does not exist or no valid version could be found
> 
> Jeremy just updated the pom to fix that. Please svn update and retry.

Next I got an error during the start up phase of Cocoon. After some 
searching I found out that target/cocoon-samples/WEB-INF/shielded/lib 
contained a avalon-framework-4.0.jar (from 2002), besides the 
avalon-framework-api-4.3.jar and avalon-framework-impl-4.3.jar that it 
is supposed to contain. The obsolete jar also was before the correct 
ones in the search order, which led to a method not found exception.

After having removed the obsolete jar and restarted, Cocoon at last 
worked. Anyone else getting the obsolete Avalon framework jar? Any idea 
why it is included, it hasn't happened before.

/Daniel

Mime
View raw message