cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carsten Ziegeler <cziege...@apache.org>
Subject [Vote] Use latest rhino in 2.1.x
Date Thu, 16 Nov 2006 12:11:55 GMT
Ok, it seems we should vote on this topic. As you all know,
including the version of rhino in 2.1.x has legal problems
and we have to do something about it.

Fortunately, the latest version of Rhino is licenced under an acceptable
term, so we could include that version in 2.1.x. Unfortunately this
creates minor incompatibilites and might infect people using specific
functions in flowscript. On the other hand, if we insist on using the
current version we can't include rhino in our releases, split out the
flow stuff from core, make it available separately, force people to
download it and download rhino from somewhere else...and so on. So in
the end we have to decide which solution hurts less for our users.
It seems that we think that using the latest version of rhino is less
pain, so let's vote on this.

Please cast your votes for using latest rhino in 2.1.x.

Carsten
-- 
Carsten Ziegeler - Chief Architect
http://www.s-und-n.de
http://www.osoco.org/weblogs/rael/

Mime
View raw message