cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carsten Ziegeler <cziege...@apache.org>
Subject Re: Javaflow/JCI dependencies
Date Thu, 02 Nov 2006 11:30:40 GMT
Can someone PLEASE either add these dependencies to a reachable
repository or uncomment the stuff. This blocks everyone trying to do
some development on Cocoon as event cocoon-bootstrap is not compilable.

Thanks
Carsten

Torsten Curdt schrieb:
>>> introduced two SNAPSHOT dependencies that are in NO repository yet!!! (to compile
you need to compile jci and javaflow trunk ...will try to fix that soon ...or whoever has
more time to fix that),
>> How can we fix that? I guess we need a release of jci and javaflow, right?
> 
> Well, that would be the best case. But for javaflow I am waiting for a
> proper working surefire plugin as the testcase are only working from
> within eclipse. (surefire does not like the classloader stuff in the
> tests) ...while we still have a few improvements to get fixed in
> javaflow I think the interfaces are stable and we could do a release
> and fix the outstanding things in the next release.
> 
> For jci that's a different story. I have been wasting most of my time
> with the build setup - which is no fun ...and I am still not happy.
> There are changes (even on the interfaces) required in order to fix an
> eclipse compiler bug and support dependency aware removal of classes.
> ...so there is a bit more that needs to be fixed. But there are
> already a few projects waiting for a release (sorry!)
> 
>> Are
>> you (we) allowed to do releases of _sandboxed_ Jakarta commons projects at all?
> 
> No ...that requires a vote from the jakarta PMC ....the only thing we
> could do is get a snaphot out into a repository ...or get some people
> help over in jakarta land (hint!) ;-)
> 
> cheers
> --
> Torsten
> 


-- 
Carsten Ziegeler - Chief Architect
http://www.s-und-n.de
http://www.osoco.org/weblogs/rael/

Mime
View raw message