cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bertrand Delacretaz" <bdelacre...@apache.org>
Subject Re: [HEADS-UP] Cocoon 2.2 and java 1.5 revisited.
Date Tue, 10 Oct 2006 06:18:33 GMT
On 10/9/06, Antonio Gallardo <agallardo@agssa.net> wrote:

> ...Because we claim 2.1 is java 1.3 when it
> fact few of us care about this compatibility and some blocks does not
> compile at all....

I think we voted on this a while ago: the 2.1 core and most blocks
must work with 1.3, but some blocks might not. So it's not a surprise.

If we want to make sure 2.1 compiles with JDK 1.3 as shipped, we could
add a notice to the release instructions, that this must be tested
before releasing - it's only a matter of disabling blocks which do not
compile with 1.3.

For 2.2, it would be cool to have this info in the blocks themselves -
do the Maven POMs allow for some "JDK requirements" metadata?

-Bertrand

Mime
View raw message