cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bertrand Delacretaz" <bdelacre...@apache.org>
Subject Re: [HEADS-UP] Cocoon 2.2 and java 1.5 revisited.
Date Mon, 09 Oct 2006 16:02:16 GMT
On 10/9/06, Antonio Gallardo <agallardo@agssa.net> wrote:

> ...I was updating some jars for cocoon 2.1.0. Qdox[1] version 1.6 was
> released in August 2006 (we are using now qdox 1.5) and it is
> distributed only for java 1.5! I know qdox is not the most used block,
> but it rings a bell!...

Does anything prevent us from having some blocks that require 1.5,
while the core and "core blocks" (we might need to define which ones
these are, but most of them are evident I thin) require 1.4?

The situation that you describe will certainly happen for other
blocks, and at the same time we might have some blocks that do not
compile with 1.5.

I think the only way to handle this is to decide on a JVM version for
the core, and accept that some "non-core" blocks might have different
requirements.

-Bertrand

Mime
View raw message