cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jorg Heymans <>
Subject Re: [HEADS-UP] Cocoon 2.2 and java 1.5 revisited.
Date Tue, 10 Oct 2006 21:06:56 GMT
Reinhard Poetz wrote:

>> For 2.2, it would be cool to have this info in the blocks themselves -
>> do the Maven POMs allow for some "JDK requirements" metadata?

not that i know of. There is the <prerequisites> element but that's only 
used for the maven version. Nothing prevents us though from just setting 
a plain property in the pom as an indication of the jdk version. I don't 
see a way of enforcing it ATM.

> You can configure the compiler plugin by setting the source and target 
> version of your code. Usually they are set in the root pom but for 
> Cocoon it has been commented out for some reasons (Jorg?)

I remember commenting it out a long time ago, probably because at the 
time it wasn't decided yet on what JDK 2.2 should be able run. Feel free 
to enable it again.


View raw message